DO NOT UPGRADE TO macOS Catalina JUST YET!

Apple Catalina Info

As some of you may be aware, Apple will soon release the Mac OS 10.15 Catalina. Currently, we cannot verify that all of the school-issued software will work on the new OS release.  Please DO NOT update your OS until we have completed testing for all software which includes post-update. Updating your system before verification of software compatibility could result in missed classwork or homework. We will notify everyone when it is safe to upgrade.

For your information, below is document which lists which apps won’t work with Catalina:

macOS 10.15 Catalina Compatibility List

LAFS IMT supports the current version: macOS Mojave 10.14.2 If you have any questions or concerns, please contact the Helpdesk Support page

Turn Off Auto Updates

We recommend you turn off auto updates on your Mac until Catalina has been tested with your program’s software. You may still continue to receive notifications to update to the new macOS, but please resist the urge to move forward with the installation as it can affect how your software functions.